import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Project\\((?<ParentProjectGuid>\\\"\\{([0-9A-Fa-f\\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\\}\\\")\\) ?\\= ?(?<ProjectName>\\\"[\\-\\\\\\w_\\. ]*\\\"),? ?(?<ProjectFilePath>\\\"[\\w\\-\\.\\\\_ ]*\\\"),\\s?(?<ProjectGuid>\\\"\\{([0-9A-Fa-f\\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\\}\\\")";
final String string = "Project(\"{25118BE4-D265-45B5-9D47-FEAA0DF793E0}\") = \"Contos.Abc.Common\", \"src\\core\\Contos.Abc.Common\\Contos.Abc.Common.csproj\", \"{B0DD9A05-01BA-4C4C-B780-EC860588A570}\"\n"
+ "Project(\"{25118BE4-D265-45B5-9D47-FEAA0DF793E0}\") = \"Contos.Abc.Common\" \"src\\core\\Contos.Abc.Common\\Contos.Abc.Common.csproj\", \"{B0DD9A05-01BA-4C4C-B780-EC860588A570}\"\n"
+ "Project(\"{C090F852-A19F-45C0-B128-3FDFCC38F79B}\") = \"Common Libraries\", \"Common Libraries\", \"{7313AD3E-A062-409C-9BE9-AB01ABA75B6F}\"\n"
+ "Project(\"{C090F852-A19F-45C0-B128-3FDFCC38F79B}\") = \"Common Libraries Test\", \"Common Libraries Test\",\n"
+ "\"{B26F531F-EFD1-4B51-89D3-DCF4F961CB67}\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}