# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Project\((?<ParentProjectGuid>\"\{([0-9A-Fa-f\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\}\")\) ?\= ?(?<ProjectName>\"[\-\\\w_\. ]*\"),? ?(?<ProjectFilePath>\"[\w\-\.\\_ ]*\"),\s?(?<ProjectGuid>\"\{([0-9A-Fa-f\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\}\")"
test_str = ("Project(\"{25118BE4-D265-45B5-9D47-FEAA0DF793E0}\") = \"Contos.Abc.Common\", \"src\\core\\Contos.Abc.Common\\Contos.Abc.Common.csproj\", \"{B0DD9A05-01BA-4C4C-B780-EC860588A570}\"\n"
"Project(\"{25118BE4-D265-45B5-9D47-FEAA0DF793E0}\") = \"Contos.Abc.Common\" \"src\\core\\Contos.Abc.Common\\Contos.Abc.Common.csproj\", \"{B0DD9A05-01BA-4C4C-B780-EC860588A570}\"\n"
"Project(\"{C090F852-A19F-45C0-B128-3FDFCC38F79B}\") = \"Common Libraries\", \"Common Libraries\", \"{7313AD3E-A062-409C-9BE9-AB01ABA75B6F}\"\n"
"Project(\"{C090F852-A19F-45C0-B128-3FDFCC38F79B}\") = \"Common Libraries Test\", \"Common Libraries Test\",\n"
"\"{B26F531F-EFD1-4B51-89D3-DCF4F961CB67}\"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.