const regex = /Project\((?<ParentProjectGuid>\"\{([0-9A-Fa-f\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\}\")\) ?\= ?(?<ProjectName>\"[\-\\\w_\. ]*\"),? ?(?<ProjectFilePath>\"[\w\-\.\\_ ]*\"),\s?(?<ProjectGuid>\"\{([0-9A-Fa-f\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\}\")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Project\\((?<ParentProjectGuid>\\"\\{([0-9A-Fa-f\\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\\}\\")\\) ?\\= ?(?<ProjectName>\\"[\\-\\\\\\w_\\. ]*\\"),? ?(?<ProjectFilePath>\\"[\\w\\-\\.\\\\_ ]*\\"),\\s?(?<ProjectGuid>\\"\\{([0-9A-Fa-f\\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\\}\\")', 'gm')
const str = `Project("{25118BE4-D265-45B5-9D47-FEAA0DF793E0}") = "Contos.Abc.Common", "src\\core\\Contos.Abc.Common\\Contos.Abc.Common.csproj", "{B0DD9A05-01BA-4C4C-B780-EC860588A570}"
Project("{25118BE4-D265-45B5-9D47-FEAA0DF793E0}") = "Contos.Abc.Common" "src\\core\\Contos.Abc.Common\\Contos.Abc.Common.csproj", "{B0DD9A05-01BA-4C4C-B780-EC860588A570}"
Project("{C090F852-A19F-45C0-B128-3FDFCC38F79B}") = "Common Libraries", "Common Libraries", "{7313AD3E-A062-409C-9BE9-AB01ABA75B6F}"
Project("{C090F852-A19F-45C0-B128-3FDFCC38F79B}") = "Common Libraries Test", "Common Libraries Test",
"{B26F531F-EFD1-4B51-89D3-DCF4F961CB67}"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}