$re = '/Project\((?<ParentProjectGuid>\"\{([0-9A-Fa-f\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\}\")\) ?\= ?(?<ProjectName>\"[\-\\\\\w_\. ]*\"),? ?(?<ProjectFilePath>\"[\w\-\.\\\\_ ]*\"),\s?(?<ProjectGuid>\"\{([0-9A-Fa-f\-]{8}(?:-[0-9A-Fa-f]{4}){3}-[0-9A-Fa-f]{12})\}\")/m';
$str = 'Project("{25118BE4-D265-45B5-9D47-FEAA0DF793E0}") = "Contos.Abc.Common", "src\\core\\Contos.Abc.Common\\Contos.Abc.Common.csproj", "{B0DD9A05-01BA-4C4C-B780-EC860588A570}"
Project("{25118BE4-D265-45B5-9D47-FEAA0DF793E0}") = "Contos.Abc.Common" "src\\core\\Contos.Abc.Common\\Contos.Abc.Common.csproj", "{B0DD9A05-01BA-4C4C-B780-EC860588A570}"
Project("{C090F852-A19F-45C0-B128-3FDFCC38F79B}") = "Common Libraries", "Common Libraries", "{7313AD3E-A062-409C-9BE9-AB01ABA75B6F}"
Project("{C090F852-A19F-45C0-B128-3FDFCC38F79B}") = "Common Libraries Test", "Common Libraries Test",
"{B26F531F-EFD1-4B51-89D3-DCF4F961CB67}"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);