#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])(?:-(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])|(?:[0-9]|[1-2][0-9]|3[0-2]))?|(?:[a-z0-9]+(?:-[a-z0-9]+)*\.)+[a-z]{2,})|((?:(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?:(\/([1-9]|[1-2]\d|3[0-1])))?)$"
Local $sString = "Valid" & @CRLF & _
"1.2.3.4" & @CRLF & _
"255.255.255.255" & @CRLF & _
"1.2.3.4-1.2.3.4" & @CRLF & _
"1.2.3.4/24" & @CRLF & _
"1.2.3.4/8" & @CRLF & _
"www.example.com" & @CRLF & _
"www.example.lv" & @CRLF & _
"www.example.com" & @CRLF & _
"" & @CRLF & _
"Invalid" & @CRLF & _
"1.2.3" & @CRLF & _
"1.2.3." & @CRLF & _
".1.2.3" & @CRLF & _
"1.2.3.4/33" & @CRLF & _
"www.-example.com" & @CRLF & _
"1.2.3.4-1.2.3.256" & @CRLF & _
"1.2.3.4.5.6.7.8 (use anchors ^ and $ to skip these if needed)" & @CRLF & _
"999.999.999.999 (use a complex regex to skip these if needed)" & @CRLF & _
"299.299.299.299" & @CRLF & _
"001.002.003.004 (these use octal notation, not decimal)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")