import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])(?:-(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])|(?:[0-9]|[1-2][0-9]|3[0-2]))?|(?:[a-z0-9]+(?:-[a-z0-9]+)*\\.)+[a-z]{2,})|((?:(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\\.){3}(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?:(\\/([1-9]|[1-2]\\d|3[0-1])))?)$";
final String string = "Valid\n"
+ "1.2.3.4\n"
+ "255.255.255.255\n"
+ "1.2.3.4-1.2.3.4\n"
+ "1.2.3.4/24\n"
+ "1.2.3.4/8\n"
+ "www.example.com\n"
+ "www.example.lv\n"
+ "www.example.com\n\n"
+ "Invalid\n"
+ "1.2.3\n"
+ "1.2.3.\n"
+ ".1.2.3\n"
+ "1.2.3.4/33\n"
+ "www.-example.com\n"
+ "1.2.3.4-1.2.3.256\n"
+ "1.2.3.4.5.6.7.8 (use anchors ^ and $ to skip these if needed)\n"
+ "999.999.999.999 (use a complex regex to skip these if needed)\n"
+ "299.299.299.299\n"
+ "001.002.003.004 (these use octal notation, not decimal)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}