# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])(?:-(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])|(?:[0-9]|[1-2][0-9]|3[0-2]))?|(?:[a-z0-9]+(?:-[a-z0-9]+)*\.)+[a-z]{2,})|((?:(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?:(\/([1-9]|[1-2]\d|3[0-1])))?)$"
test_str = ("Valid\n"
"1.2.3.4\n"
"255.255.255.255\n"
"1.2.3.4-1.2.3.4\n"
"1.2.3.4/24\n"
"1.2.3.4/8\n"
"www.example.com\n"
"www.example.lv\n"
"www.example.com\n\n"
"Invalid\n"
"1.2.3\n"
"1.2.3.\n"
".1.2.3\n"
"1.2.3.4/33\n"
"www.-example.com\n"
"1.2.3.4-1.2.3.256\n"
"1.2.3.4.5.6.7.8 (use anchors ^ and $ to skip these if needed)\n"
"999.999.999.999 (use a complex regex to skip these if needed)\n"
"299.299.299.299\n"
"001.002.003.004 (these use octal notation, not decimal)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.