$re = '/^(?:(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])(?:-(?:(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])\.){3}(?:25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[0-9])|(?:[0-9]|[1-2][0-9]|3[0-2]))?|(?:[a-z0-9]+(?:-[a-z0-9]+)*\.)+[a-z]{2,})|((?:(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])\.){3}(?:[0-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?:(\/([1-9]|[1-2]\d|3[0-1])))?)$/m';
$str = 'Valid
1.2.3.4
255.255.255.255
1.2.3.4-1.2.3.4
1.2.3.4/24
1.2.3.4/8
www.example.com
www.example.lv
www.example.com
Invalid
1.2.3
1.2.3.
.1.2.3
1.2.3.4/33
www.-example.com
1.2.3.4-1.2.3.256
1.2.3.4.5.6.7.8 (use anchors ^ and $ to skip these if needed)
999.999.999.999 (use a complex regex to skip these if needed)
299.299.299.299
001.002.003.004 (these use octal notation, not decimal)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);