using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=dnsmasq-dhcp\[6292\]\:)(.*)(?=\()";
string input = @"Jun 27 07:01:03 192.168.68.1 Jun 27 03:01:03 dmpromjwillekecom,50c9676c6d24,udm-1.9.3.3438 dnsmasq-dhcp[6292]: DHCPOFFER(br0) 192.168.68.53 f4:f5:d8:a6:9e:54";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}