const regex = /(?<=dnsmasq-dhcp\[6292\]\:)(.*)(?=\()/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=dnsmasq-dhcp\\[6292\\]\\:)(.*)(?=\\()', 'gm')
const str = `Jun 27 07:01:03 192.168.68.1 Jun 27 03:01:03 dmpromjwillekecom,50c9676c6d24,udm-1.9.3.3438 dnsmasq-dhcp[6292]: DHCPOFFER(br0) 192.168.68.53 f4:f5:d8:a6:9e:54`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}