$re = '/(?<=dnsmasq-dhcp\[6292\]\:)(.*)(?=\()/m';
$str = 'Jun 27 07:01:03 192.168.68.1 Jun 27 03:01:03 dmpromjwillekecom,50c9676c6d24,udm-1.9.3.3438 dnsmasq-dhcp[6292]: DHCPOFFER(br0) 192.168.68.53 f4:f5:d8:a6:9e:54';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);