import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<distanceMeter>\\d+(?:[,.]\\d+)?)(?: ?\\/ ?(?<distanceFemaleMeter>\\d+(?:[,.]\\d+)?))? ?-m ?(?<text>\\w+(?: \\w+)*)";
final String string = "2000/ 1,500-m row and\n"
+ "2000-m row\n"
+ "But it fails to match\n\n"
+ "10/ 5-m row\n"
+ "9-m row";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}