const regex = /^(?<distanceMeter>\d+(?:[,.]\d+)?)(?: ?\/ ?(?<distanceFemaleMeter>\d+(?:[,.]\d+)?))? ?-m ?(?<text>\w+(?: \w+)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<distanceMeter>\\d+(?:[,.]\\d+)?)(?: ?\\\/ ?(?<distanceFemaleMeter>\\d+(?:[,.]\\d+)?))? ?-m ?(?<text>\\w+(?: \\w+)*)', 'gm')
const str = `2000/ 1,500-m row and
2000-m row
But it fails to match
10/ 5-m row
9-m row`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}