re = /^(?<distanceMeter>\d+(?:[,.]\d+)?)(?: ?\/ ?(?<distanceFemaleMeter>\d+(?:[,.]\d+)?))? ?-m ?(?<text>\w+(?: \w+)*)/m
str = '2000/ 1,500-m row and
2000-m row
But it fails to match
10/ 5-m row
9-m row'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end