#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?[1]?[2-9]{1}11$"
Local $sString = "211" & @CRLF & _
"311" & @CRLF & _
"411" & @CRLF & _
"511" & @CRLF & _
"611" & @CRLF & _
"711" & @CRLF & _
"811" & @CRLF & _
"911" & @CRLF & _
"+211" & @CRLF & _
"+311" & @CRLF & _
"+411" & @CRLF & _
"+511" & @CRLF & _
"+611" & @CRLF & _
"+711" & @CRLF & _
"+811" & @CRLF & _
"+911" & @CRLF & _
"+1211" & @CRLF & _
"+1311" & @CRLF & _
"+1411" & @CRLF & _
"+1511" & @CRLF & _
"+1611" & @CRLF & _
"+1711" & @CRLF & _
"+1811" & @CRLF & _
"+1911" & @CRLF & _
"2114123" & @CRLF & _
"+2114123" & @CRLF & _
"+12114123" & @CRLF & _
"911911" & @CRLF & _
"411411" & @CRLF & _
"311511" & @CRLF & _
"+911911" & @CRLF & _
"+4119"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")