import re
regex = re.compile(r"^\+?[1]?[2-9]{1}11$", flags=re.MULTILINE)
test_str = ("211\n"
"311\n"
"411\n"
"511\n"
"611\n"
"711\n"
"811\n"
"911\n"
"+211\n"
"+311\n"
"+411\n"
"+511\n"
"+611\n"
"+711\n"
"+811\n"
"+911\n"
"+1211\n"
"+1311\n"
"+1411\n"
"+1511\n"
"+1611\n"
"+1711\n"
"+1811\n"
"+1911\n"
"2114123\n"
"+2114123\n"
"+12114123\n"
"911911\n"
"411411\n"
"311511\n"
"+911911\n"
"+4119")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")