$re = '/^\+?[1]?[2-9]{1}11$/m';
$str = '211
311
411
511
611
711
811
911
+211
+311
+411
+511
+611
+711
+811
+911
+1211
+1311
+1411
+1511
+1611
+1711
+1811
+1911
2114123
+2114123
+12114123
911911
411411
311511
+911911
+4119';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);