using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(dont.*done.*?\K)?(dont(?!.*done).*(*SKIP)(*FAIL))?mul";
string input = @"mul mul dont done mul mul done mul mul
mul mul done mul mul
mul mul dont mul mul
mul mul done mul mul dont mul mul";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}