import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(dont.*done.*?\\K)?(dont(?!.*done).*(*SKIP)(*FAIL))?mul";
final String string = "mul mul dont done mul mul done mul mul\n\n"
+ "mul mul done mul mul\n"
+ "mul mul dont mul mul\n"
+ "mul mul done mul mul dont mul mul";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}