$re = '/(dont.*done.*?\K)?(dont(?!.*done).*(*SKIP)(*FAIL))?mul/m';
$str = 'mul mul dont done mul mul done mul mul
mul mul done mul mul
mul mul dont mul mul
mul mul done mul mul dont mul mul';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);