const regex = /(dont.*done.*?\K)?(dont(?!.*done).*(*SKIP)(*FAIL))?mul/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(dont.*done.*?\\K)?(dont(?!.*done).*(*SKIP)(*FAIL))?mul', 'gm')
const str = `mul mul dont done mul mul done mul mul
mul mul done mul mul
mul mul dont mul mul
mul mul done mul mul dont mul mul`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}