$re = '/^\b[a-z0-9](?:[-._]?[a-z0-9]+)*\b@(?:[a-z0-9](?:\-?[a-z0-9]+)*\.)+[a-z]{2,}$/i';
$str = 'i@3s-d.ds';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);