import Foundation
let pattern = #"^\b[a-z0-9](?:[-._]?[a-z0-9]+)*\b@(?:[a-z0-9](?:\-?[a-z0-9]+)*\.)+[a-z]{2,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"i@3s-d.ds"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}