// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^\b[a-z0-9](?:[-._]?[a-z0-9]+)*\b@(?:[a-z0-9](?:\-?[a-z0-9]+)*\.)+[a-z]{2,}$").unwrap();
let string = "i@3s-d.ds";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}