using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!$)\\nstart[\s\S]*?$";
string input = @"total abc total foo total anything here total\ntotal total\ntotal\nstart\notal abc total foo total anything here total\notal abc total foo total anything here total\nstart\notal abc total foo total anything here total\n";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}