$re = '/(?!$)\\\\nstart[\s\S]*?$/m';
$str = 'total abc total foo total anything here total\\ntotal total\\ntotal\\nstart\\notal abc total foo total anything here total\\notal abc total foo total anything here total\\nstart\\notal abc total foo total anything here total\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);