import re
regex = re.compile(r"(?!$)\\nstart[\s\S]*?$", flags=re.MULTILINE)
test_str = "total abc total foo total anything here total\\ntotal total\\ntotal\\nstart\\notal abc total foo total anything here total\\notal abc total foo total anything here total\\nstart\\notal abc total foo total anything here total\\n"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")