re = /(?!$)\\nstart[\s\S]*?$/m
str = 'total abc total foo total anything here total\\ntotal total\\ntotal\\nstart\\notal abc total foo total anything here total\\notal abc total foo total anything here total\\nstart\\notal abc total foo total anything here total\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end