# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http)?s?(:\\/\\/)?kiwifarms\.(net|top|is|ru)\\//http:\/\/kiwifarmsaaf4t2h7gc3dfc5ojhmqruw2nit3uejrpiagrxeuxiyxcyd.onion\//gm;t' <<< "http://kiwifarms.net/path/to/something
https://kiwifarms.net/path/to/something
kiwifarms.net/path/to/something
kiwifarms.net
http://kiwifarms.top/path/to/something
https://kiwifarms.top/path/to/something
kiwifarms.top/path/to/something
kiwifarms.top
https://kiwifarms.other.com/something"