use strict;
my $str = 'http://kiwifarms.net/path/to/something
https://kiwifarms.net/path/to/something
kiwifarms.net/path/to/something
kiwifarms.net
http://kiwifarms.top/path/to/something
https://kiwifarms.top/path/to/something
kiwifarms.top/path/to/something
kiwifarms.top
https://kiwifarms.other.com/something';
my $regex = qr/(http)?s?(:\/\/)?kiwifarms\.(net|top|is|ru)\//mp;
my $subst = 'http://kiwifarmsaaf4t2h7gc3dfc5ojhmqruw2nit3uejrpiagrxeuxiyxcyd.onion/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";