const regex = /(http)?s?(:\/\/)?kiwifarms\.(net|top|is|ru)\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http)?s?(:\\\/\\\/)?kiwifarms\\.(net|top|is|ru)\\\/', 'gm')
const str = `http://kiwifarms.net/path/to/something
https://kiwifarms.net/path/to/something
kiwifarms.net/path/to/something
kiwifarms.net
http://kiwifarms.top/path/to/something
https://kiwifarms.top/path/to/something
kiwifarms.top/path/to/something
kiwifarms.top
https://kiwifarms.other.com/something`;
const subst = `http://kiwifarmsaaf4t2h7gc3dfc5ojhmqruw2nit3uejrpiagrxeuxiyxcyd.onion/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);