re = /(http)?s?(:\/\/)?kiwifarms\.(net|top|is|ru)\//m
str = 'http://kiwifarms.net/path/to/something
https://kiwifarms.net/path/to/something
kiwifarms.net/path/to/something
kiwifarms.net
http://kiwifarms.top/path/to/something
https://kiwifarms.top/path/to/something
kiwifarms.top/path/to/something
kiwifarms.top
https://kiwifarms.other.com/something'
subst = 'http://kiwifarmsaaf4t2h7gc3dfc5ojhmqruw2nit3uejrpiagrxeuxiyxcyd.onion/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result