using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?(?![\d.]+)(?=\w+\.\w+\.\w+)(?<RawHost>[^\s]+)";
string input = @"server1 10.10.10.10 server2.atmydomain.com
server1 server3.atmydomain.com 10.10.10.10
server4.atmydomain.com 10.10.10.10 server1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}