$re = '~.*?(?![\d.]+)(?=\w+\.\w+\.\w+)(?<RawHost>[^\s]+)~';
$str = 'server1 10.10.10.10 server2.atmydomain.com
server1 server3.atmydomain.com 10.10.10.10
server4.atmydomain.com 10.10.10.10 server1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);