use strict;
my $str = 'server1 10.10.10.10 server2.atmydomain.com
server1 server3.atmydomain.com 10.10.10.10
server4.atmydomain.com 10.10.10.10 server1';
my $regex = qr~.*?(?![\d.]+)(?=\w+\.\w+\.\w+)(?<RawHost>[^\s]+)~p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}