#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\$)((^|\$)(?=[^$\n]*[1-9])(\d+(\.\d*)?|(\.\d*)?\d+)){3}$"
Local $sString = "123$53$12" & @CRLF & _
"123$0$12" & @CRLF & _
"0$53$12" & @CRLF & _
"123$53$0" & @CRLF & _
"123.43$.03$123.0" & @CRLF & _
"123$000000$12" & @CRLF & _
"0.0000$53$12" & @CRLF & _
"123$53$.000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")