use strict;
my $str = '123$53$12
123$0$12
0$53$12
123$53$0
123.43$.03$123.0
123$000000$12
0.0000$53$12
123$53$.000';
my $regex = qr/^(?!\$)((^|\$)(?=[^$\n]*[1-9])(\d+(\.\d*)?|(\.\d*)?\d+)){3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}