import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\$)((^|\\$)(?=[^$\\n]*[1-9])(\\d+(\\.\\d*)?|(\\.\\d*)?\\d+)){3}$";
final String string = "123$53$12\n"
+ "123$0$12\n"
+ "0$53$12\n"
+ "123$53$0\n"
+ "123.43$.03$123.0\n"
+ "123$000000$12\n"
+ "0.0000$53$12\n"
+ "123$53$.000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}