re = /^(?!\$)((^|\$)(?=[^$\n]*[1-9])(\d+(\.\d*)?|(\.\d*)?\d+)){3}$/m
str = '123$53$12
123$0$12
0$53$12
123$53$0
123.43$.03$123.0
123$000000$12
0.0000$53$12
123$53$.000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end