# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((On|Em)\s+(?:[0-3]?[0-9][\s,\\/\.\-]*(?:(?:th)|(?:st)|(?:nd)|(?:rd))?.*?(?:(?:Jan(?:uary)?)|(?:[Jj]an(?:eiro)?)|(?:Feb(?:ruary)?)|(?:[Ff]ev(?:ereiro)?)|(?:Mar(?:ch)?)|(?:[Mm]ar(?:ço)?)|(?:Apr(?:il)?)|(?:[Aa]br(?:il)?)|(?:May)|(?:[Mm]ai(?:o)?)|(?:Jun(?:e)?)|(?:[Jj]un(?:ho)?)|(?:Jul(?:y)?)|(?:[Jj]ul(?:ho)?)|(?:Aug(?:ust)?)|(?:[Aa]go(?:sto)?)|(?:Sep(?:tember)?)|(?:[Ss]et(?:embro)?)|(?:Oct(?:ober)?)|(?:[Oo]ut(?:ubro)?)|(?:Nov(?:ember)?)|(?:[Nn]ov(?:embro)?)|(?:Dec(?:ember)?)|(?:[Dd]ez(?:embro)?)|(?:[0-1]?[0-9])).*(?:[1-2]?[0-9])[0-9][0-9][\s,\\/\.\-](?:[0-2])?[0-9]:[0-5][0-9](?::[0-5][0-9])?(?:(?:\s)?[AP]M)?).*(wrote|escreveu):\s+)//gs;t' <<< "Nos dois sistemas.
> ##- Não escreva abaixo desta linha -##
>
> *Comentário adicionado por FERNANDO TEIXEIRA BARROS em 22/05/2018 10:23*
> *Usuário:* FERNANDO TEIXEIRA BARROS* Data:* 22/05/2018 10:23:25
>
> *COMENTÁRIO:*
> Bom dia Mayla,
> Apenas sistema Montafarma?
> ------------------------------
>
> *ID Reporte: * #1468
> *Situação: * *ABERTO*
> *Módulo:* Produção
> *Tela:* ordem de pedido
> *Nome: * mayla.capana - MAYLA CAPANA
> *Emissão: * 22/05/2018 12:00:00
> *Fechamento: * -
> *Responsável: * DELTA SI
> *Prioridade: * Urgente
> *Tipo: * Ajuda
>
> *MENSAGEM: *
> Bom dia,
>
> Por favor liberar o meu acesso, Izac e Priscila, para a tela de Produção -
> Ordem de Pedido. (igual a tela que a Iza tem acesso).
>
> Aguardo retorno.
>
> Até,
>
>"