using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\b[-a-zA-Z0-9*]+)\s*=\s*(['\""]?)(.*?)(\2))(?=\s*;\s*|\s*$)";
string input = @"filename*0*=UTF-8''vallalkozasi_szerzodes_ceggel_es_egyeni_vallalkozoval_; filename*1*=reszteljesitessel_HAH_Pilis.doc; size=83968";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}