const regex = new RegExp('(?:(\\b[-a-zA-Z0-9*]+)\\s*=\\s*([\\'\\"]?)(.*?)(\\2))(?=\\s*;\\s*|\\s*$)', 'gm')
const str = `filename*0*=UTF-8''vallalkozasi_szerzodes_ceggel_es_egyeni_vallalkozoval_; filename*1*=reszteljesitessel_HAH_Pilis.doc; size=83968`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}