use strict;
my $str = 'filename*0*=UTF-8\'\'vallalkozasi_szerzodes_ceggel_es_egyeni_vallalkozoval_; filename*1*=reszteljesitessel_HAH_Pilis.doc; size=83968';
my $regex = qr/(?:(\b[-a-zA-Z0-9*]+)\s*=\s*(['\"]?)(.*?)(\2))(?=\s*;\s*|\s*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}