import re
regex = re.compile(r"(?:(\b[-a-zA-Z0-9*]+)\s*=\s*(['\"]?)(.*?)(\2))(?=\s*;\s*|\s*$)", flags=re.MULTILINE)
test_str = "filename*0*=UTF-8''vallalkozasi_szerzodes_ceggel_es_egyeni_vallalkozoval_; filename*1*=reszteljesitessel_HAH_Pilis.doc; size=83968"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")