#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]+)\s*(.*?)\.\s(.*?)(?:\s*([0-9]+))?$"
Local $sString = "8 EXT./INT. MONORAIL - MORNING 8" & @CRLF & _
"9 EXT. CITY SCAPE/MONORAIL - CONTINUOUS 9" & @CRLF & _
"9 EXT. CITY SCAPE/MONORAIL - CONTINUOUS"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")