import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]+)\\s*(.*?)\\.\\s(.*?)(?:\\s*([0-9]+))?$";
final String string = "8 EXT./INT. MONORAIL - MORNING 8\n"
+ "9 EXT. CITY SCAPE/MONORAIL - CONTINUOUS 9\n"
+ "9 EXT. CITY SCAPE/MONORAIL - CONTINUOUS";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}