$re = '/^([0-9]+)\s*(.*?)\.\s(.*?)(?:\s*([0-9]+))?$/m';
$str = '8 EXT./INT. MONORAIL - MORNING 8
9 EXT. CITY SCAPE/MONORAIL - CONTINUOUS 9
9 EXT. CITY SCAPE/MONORAIL - CONTINUOUS';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);