package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w*?(p).*([a])[^l]*(l)[a-zA-Z\d]*?(a)({)\w*?(o).+([W-w])(h)[^f]+(f).*`)
var str = `LZckWnfFS0NyHyjMpObY0aLi:cVJVcVZkWnfFS0NvlQNiyZa{NVCHJ6zWPPI5KXxGZyUo55ywhR8LzVm4KM92kSfi}fzQHpjMpOb0ii?`
var substitution = "\9\3\2g\5t\7\6ste\1s\4\8e\2d}"
fmt.Println(re.ReplaceAllString(str, substitution))
}