// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w*?(p).*([a])[^l]*(l)[a-zA-Z\d]*?(a)({)\w*?(o).+([W-w])(h)[^f]+(f).*").unwrap();
let string = "LZckWnfFS0NyHyjMpObY0aLi:cVJVcVZkWnfFS0NvlQNiyZa{NVCHJ6zWPPI5KXxGZyUo55ywhR8LzVm4KM92kSfi}fzQHpjMpOb0ii?";
let substitution = "\\9\\3\\2g\\5t\\7\\6ste\\1s\\4\\8e\\2d}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}