import re
regex = re.compile(r"\w*?(p).*([a])[^l]*(l)[a-zA-Z\d]*?(a)({)\w*?(o).+([W-w])(h)[^f]+(f).*")
test_str = "LZckWnfFS0NyHyjMpObY0aLi:cVJVcVZkWnfFS0NvlQNiyZa{NVCHJ6zWPPI5KXxGZyUo55ywhR8LzVm4KM92kSfi}fzQHpjMpOb0ii?"
subst = "\\9\\3\\2g\\5t\\7\\6ste\\1s\\4\\8e\\2d}"
result = regex.sub(subst, test_str)
if result:
print(result)